Ruby master - Feature #16796: Assigning local variables when using `case when...
sawa wrote:I have met such use cases, and agree this would be useful.I don't disagree in the sense that there may be valid use cases, but the syntax is kind of weird:/s(?<mid>.)r/ I use regexes a...
View ArticleRuby master - Feature #16799: Add more functional features,make ruby more...
method1 = (f,n) -> do return f(n) end I think a syntax change such as this may be very problematic.People would not typically expect this, and even if we, say, assume that this may be a better...
View ArticleRuby master - Feature #16816: Prematurely terminated Enumerator should stay...
( Just a brief typo-correction, I think you meant the link https://github.com/jruby/jruby/issues/6157 and not https://github.com/jruby/jruby/issue/6157 )
View ArticleRuby master - Feature #16818: Rename `Range#%` to `Range#/`
I somewhat agree with sawa's comment that % on Range may confuse some ruby folks; I think % is more typically the modulo operator? I can not say how strong this confusion may be, perhaps small, perhaps...
View ArticleRuby master - Feature #16822: Array slicing: nils and edge cases
I do not have a strong preference here either way; I guess one can reason in favour for both behaviour types/styles, and I think a primary point in the suggestion is that it refers to startless/endless...
View ArticleRuby master - Feature #16824: Follow RubyGems naming conventions for the stdlib
The optionparser situation is indeed quite ... peculiar to me:require 'optparse' OptionParser.new My brain has a hard time with it. I'd prefer:require 'optionparser' orrequire 'option_parser' # <-...
View ArticleRuby master - Feature #16828: Introduce find patterns
Is this a bit like .scan(), but applied to the pattern matching style? (Not sure if I understood this completely but it reminds me a bit of using .scan() and MatchData on the result possibly.)
View ArticleRuby master - Feature #16832: Use #name rather than #inspect to build...
Nobu recommended creating an issue request here, so I won't comment on that in itself - but I would like to point out that ruby users may wonder why/if/how to use #name rather than #inspect, if...
View ArticleRuby master - Feature #16833: Add Enumerable#empty?
sawa wrote:If that was what you meant, then that is not the case. Array mixes-in Enumerable, not Enumerator.Happens to me as well a lot - I always mix these two up. May be because the name is so...
View ArticleRuby master - Feature #16837: Can we make Ruby 3.0 as fast as Ruby 2.7 with...
I have a question concerning one point mentioned above.k0kubun wrote:Provide .so for an assertion-enabled mode? (ko1's idea)Could someone briefly explain the general idea behind this? I assume for a...
View ArticleRuby master - Feature #15921: R-assign (rightward-assignment) operator
I do not have any particularly strong opinion either way, but I would like to point out that the example given by duerst made the most sense to me personally, from all the examples given above as to...
View ArticleRuby master - Bug #16844: I want to upgrade ruby for metasploit environment....
How did you install ruby there? One-click installer? If so then I am not sure why you attempt to install rvm. I don't think that is necessary; back when I used ruby on windows sometimes, the one-click...
View ArticleRuby master - Bug #16853: calling bla(hash, **kw) with a string-based hash...
Hmm. I am confused about the example though.Isn'tbla "some" => "string" actuallybla( { "some" => "string" } ) ?
View ArticleRuby master - Bug #16854: Using (...) when the method name is a keyword...
Interesting find and explanation.
View ArticleRuby master - Feature #16847: Cache instruction sequences by default
I think python changed that default mostly because it can be annoying to see all .py files give rise to .pyc files in the very same working directory.(I know way too little to comment on the content of...
View ArticleRuby master - Misc #16890 (Rejected): [Ruby Keywords and Ruby 3.0 release]...
As some folks may already have read/heard, matz is asking for feedback.He specifically asked this in regards to the rails devs, and the rails ecosystem but this may be relevant to all ruby users.You...
View ArticleRuby master - Misc #16890: [Ruby Keywords and Ruby 3.0 release] Feedback to...
The discussion at https://discuss.rubyonrails.org/t/new-2-7-3-0-keyword-argument-pain-point/74980/2 is already quite long, and I do not intend to add to the discussion there, largely because I think it...
View ArticleRuby master - Feature #16899: Add method `Array#both_end`
I think #first_last would be a better name as well; primary reason being that we already have #first and #last.I am also ok with the proposal itself, although I think I have not had a need to use this...
View ArticleRuby master - Feature #16894: Integer division for Ruby 3
I am not necessarily against such a change per se, but I think it would come with a high cost right now. It should perhaps be discussed more for ruby 4.0 or so.By the way, mruby behaves in a similar...
View ArticleRuby master - Misc #16775: DevelopersMeeting20200514Japan
mame wrote:[...] We'll hold an extra meeting at 26th.\o/
View Article