The optionparser situation is indeed quite ... peculiar to me:
require 'optparse'
OptionParser.new
My brain has a hard time with it. I'd prefer:
require 'optionparser'
or
require 'option_parser' # <- would probably be best.
Anyway - I don't have a strong preference, but personally I agree with havenwood (shan).
If one issue is backwards compatibility or other gems that do the same, then that
could go for consideration in ruby 4.0 perhaps, so years from now on.
zverok wrote:
I remember there was a quirk require "openstruct" → ugh, oh, require "ostruct".
Yeah, similar to optparse. I guess you can reason that 'ostruct' is shorter to
write than 'openstruct', but I myself prefer a consistent naming. But as said,
I don't have a big preference really.