Ruby master - Feature #16752: :private param for const_set
I somewhat agree with sawa here.This may still leave the issue over whether one may prefer a single line/method call, but I believe this may largely depend on the use case more (if there is one). I can...
View ArticleRuby master - Feature #16754: Pager for `--help`
I think the basic idea for the suggestion is fine.There may be cases where the ruby user may prefer to not use (or depend) on a page and may be fine with a long message output from --help. This may...
View ArticleRuby master - Feature #16754: Pager for `--help`
Oh... I just noticed in the code, I think that is the environment variable?My C knowledge is so bad, but I guess getenv() indicates that. :Dconstchar*pager_env=getenv("RUBY_PAGER");
View ArticleRuby master - Feature #16755: warning: `if' at the end of line without an...
You can filter the warnings by overriding Warning.warn, or using the warning gem:require 'warning' Warning.ignore(/`(els)?if' at the end of line without an expression/) That's pretty cool! I did not...
View ArticleRuby master - Misc #16778: Should we stop vendoring default gems code?
I believe that all of that kind of defeats the point of "gemification" of the standard library.If I remember correctly then this was not the only reason made in favour of gemifying core. One, for...
View ArticleRuby master - Feature #16786: Light-weight scheduler for improved concurrency.
One issue I see is that this adds another API (Scheduler) for people to have to remember. They will have to know how/when to use Mutex, Thread, Fibers, perhaps Guilds, and now Scheduler.Is this really...
View ArticleRuby master - Feature #16791: Shortcut for Process::Status.exitstatus
This is not a good feature request, IMO.There is not really any explanation as to what the idea is about. Why is p pid and s existatus suddenly? And why should that be common if one can already extend...
View ArticleRuby master - Feature #16794: Rightward operators
It's an interesting idea. I am not sure if I can easily adjust to the syntax, but this may be best to just ask matz directly (I think he suggested the pipeline operator, and streem kind of also taps...
View ArticleRuby master - Feature #16795: build ruby.exe on Windows against...
I feel you here. Not so much due to windows, but I totally understand every preference for --enable-shared and --enable static. :-)Perhaps nobu and greg can help for the windows-related issues; perhaps...
View ArticleRuby master - Feature #16796: Assigning local variables when using `case when...
sawa wrote:I have met such use cases, and agree this would be useful.I don't disagree in the sense that there may be valid use cases, but the syntax is kind of weird:/s(?<mid>.)r/ I use regexes a...
View ArticleRuby master - Feature #16799: Add more functional features,make ruby more...
method1 = (f,n) -> do return f(n) end I think a syntax change such as this may be very problematic.People would not typically expect this, and even if we, say, assume that this may be a better...
View ArticleRuby master - Feature #16816: Prematurely terminated Enumerator should stay...
( Just a brief typo-correction, I think you meant the link https://github.com/jruby/jruby/issues/6157 and not https://github.com/jruby/jruby/issue/6157 )
View ArticleRuby master - Feature #16818: Rename `Range#%` to `Range#/`
I somewhat agree with sawa's comment that % on Range may confuse some ruby folks; I think % is more typically the modulo operator? I can not say how strong this confusion may be, perhaps small, perhaps...
View ArticleRuby master - Feature #16822: Array slicing: nils and edge cases
I do not have a strong preference here either way; I guess one can reason in favour for both behaviour types/styles, and I think a primary point in the suggestion is that it refers to startless/endless...
View ArticleRuby master - Feature #16824: Follow RubyGems naming conventions for the stdlib
The optionparser situation is indeed quite ... peculiar to me:require 'optparse' OptionParser.new My brain has a hard time with it. I'd prefer:require 'optionparser' orrequire 'option_parser' # <-...
View ArticleRuby master - Feature #16828: Introduce find patterns
Is this a bit like .scan(), but applied to the pattern matching style? (Not sure if I understood this completely but it reminds me a bit of using .scan() and MatchData on the result possibly.)
View ArticleRuby master - Feature #16832: Use #name rather than #inspect to build...
Nobu recommended creating an issue request here, so I won't comment on that in itself - but I would like to point out that ruby users may wonder why/if/how to use #name rather than #inspect, if...
View ArticleRuby master - Feature #16833: Add Enumerable#empty?
sawa wrote:If that was what you meant, then that is not the case. Array mixes-in Enumerable, not Enumerator.Happens to me as well a lot - I always mix these two up. May be because the name is so...
View ArticleRuby master - Feature #16837: Can we make Ruby 3.0 as fast as Ruby 2.7 with...
I have a question concerning one point mentioned above.k0kubun wrote:Provide .so for an assertion-enabled mode? (ko1's idea)Could someone briefly explain the general idea behind this? I assume for a...
View ArticleRuby master - Feature #15921: R-assign (rightward-assignment) operator
I do not have any particularly strong opinion either way, but I would like to point out that the example given by duerst made the most sense to me personally, from all the examples given above as to...
View ArticleRuby master - Bug #16844: I want to upgrade ruby for metasploit environment....
How did you install ruby there? One-click installer? If so then I am not sure why you attempt to install rvm. I don't think that is necessary; back when I used ruby on windows sometimes, the one-click...
View ArticleRuby master - Bug #16853: calling bla(hash, **kw) with a string-based hash...
Hmm. I am confused about the example though.Isn'tbla "some" => "string" actuallybla( { "some" => "string" } ) ?
View ArticleRuby master - Bug #16854: Using (...) when the method name is a keyword...
Interesting find and explanation.
View ArticleRuby master - Feature #16847: Cache instruction sequences by default
I think python changed that default mostly because it can be annoying to see all .py files give rise to .pyc files in the very same working directory.(I know way too little to comment on the content of...
View ArticleRuby master - Misc #16890 (Rejected): [Ruby Keywords and Ruby 3.0 release]...
As some folks may already have read/heard, matz is asking for feedback.He specifically asked this in regards to the rails devs, and the rails ecosystem but this may be relevant to all ruby users.You...
View ArticleRuby master - Misc #16890: [Ruby Keywords and Ruby 3.0 release] Feedback to...
The discussion at https://discuss.rubyonrails.org/t/new-2-7-3-0-keyword-argument-pain-point/74980/2 is already quite long, and I do not intend to add to the discussion there, largely because I think it...
View ArticleRuby master - Feature #16899: Add method `Array#both_end`
I think #first_last would be a better name as well; primary reason being that we already have #first and #last.I am also ok with the proposal itself, although I think I have not had a need to use this...
View ArticleRuby master - Feature #16894: Integer division for Ruby 3
I am not necessarily against such a change per se, but I think it would come with a high cost right now. It should perhaps be discussed more for ruby 4.0 or so.By the way, mruby behaves in a similar...
View ArticleRuby master - Misc #16775: DevelopersMeeting20200514Japan
mame wrote:[...] We'll hold an extra meeting at 26th.\o/
View ArticleRuby master - Bug #16905: Ruby required to build Ruby on Haiku?
This could perhaps be a bug. I think you can normally build "miniruby" if a base ruby is not available on the computer system, and then the compilation step uses that miniruby for the compilation part....
View ArticleRuby master - Bug #16918: Dir.mktmpdir should yield a copy of the dir to...
Makes sense to me what headius wrote, so if there are no side effects (I have too little experience with Dir.mktmpdir myself) +1 to the suggestion from me.
View ArticleRuby master - Feature #16848: Allow callables in $LOAD_PATH
This was recently discussed:https://github.com/ruby/dev-meeting-log/blob/master/DevelopersMeeting20200514Japan.mdko1 will reply.I have no particular opinion per se on this suggestion. But one thing...
View ArticleRuby master - Feature #16897: General purpose memoizer in Ruby 3 with Ruby 2...
Matz makes the final decisions, but I would like to point out that adding *** all of a sudden may be confusing:Ruby users may have to distinguish between *, **, and ***. And ..., too.I of course can...
View ArticleRuby master - Feature #16939: Alias _1 as _ for block numbered params
I like to use _. I can see one benefit of your suggestion being that it is slightly shorter. I am mostly neutral on the suggestion but perhaps leaning towards a bit in favour (I have not thought it...
View ArticleRuby master - Misc #16944: questions about Net::IMAP patches
I believe your question is for the ruby core team, so probably it is best to let nobu or shyouhei or anyone else from the core team who would like to comment.Personally I think what you described...
View ArticleRuby master - Feature #16946: Add an `intersperse` method
Interesting idea.In particular that use case:'Hello'.intersperse('-') # => "H-e-l-l-o"I actually had that use case every now and then, in a related manner.For example in bioinformatics, you may have...
View ArticleRuby master - Feature #16986: Anonymous Struct literal
First, I like the idea, so +1 for the idea. It also reminds me of a more "prototypic-based approach" in general with structs, so if the syntax could be made simpler to type, that seems to be a possible...
View ArticleRuby master - Feature #16985: Improve `pp` for `Hash` and `String`
I don't have any big preference, but I tend to agree with sawa too.When I first read the proposal, I was confused in that two suggestions seem to be combined - or at the least I was reading it that...
View ArticleRuby master - Feature #17171: Why is the visibility of constants not affected...
I am not quite as active on the bug-tracker as I used to be in the past, but I will comment on this particular issue since the reasoning given makes sense to me.I will not comment on the...
View ArticleRuby master - Feature #17265: Add `Bool` module
I tried to make a shorter summary of my thoughts here, so just three points - hopefully that makes it easier to read:(1) Most of the discussion, I think, happened at...
View ArticleRuby master - Feature #17288: Optimize __send__ call with a literal method name
Just a few things:We need to also remember .instance_variable_get() and .instance_variable_set().Ruby does not quite use a similar "restriction-style" OOP like, say, java. It will depend a lot on the...
View ArticleRuby master - Bug #17419: `binding.eval` backtrace differente
I think this is an intended change; it was explained via a link to a comment in another issue (I think by mame or someone else, where matz commented on reverting the behaviour). If I remember the...
View ArticleRuby master - Misc #17399: Are endless methods experimental?
I guess the discussion here may be more what exactly "experimental" means, similar to what people expect a "constant" to be (non-changable, but if you come from the point of view of ruby's philosophy...
View ArticleRuby master - Feature #17474: Interpreting constants at compile time
New year, new comment! :Djzakiya wrote:Ruby has borrowed concepts/idioms from allot of languages.This is true; ruby has always been multi-paradigm and " more than one way ", even though I think its...
View ArticleRuby master - Feature #17579 (Open): [Proposal] A suggestion for...
New year, new proposal! :)Summary (TL;DR) of the proposal first: It is here proposed that ruby adds functionality to allow ruby users to create arrays, with (string) members inside that array that may...
View ArticleRuby master - Feature #17749: Const source location without name
Personally I agree with Aaron's use case or the general potential usefulness of being able to query const_source_location where Aaron's suggestion is a simplification over A::B (because the ruby user...
View ArticleRuby master - Feature #17762: A simple way to trace object allocation
I think this is a good suggestion.Please correct me if my assumptions are wrong, but if I understood the general gist of it correctly then the main point here is that, rather than focusing on specific...
View ArticleRuby master - Feature #17768: Proposal: Downward assignments
plot twist by mame similar to last year:It's actually not a joke. :)plot twist by matz this year:He actually WILL approve joke suggestions this year.
View ArticleRuby master - Feature #17786: Proposal: new "ends" keyword
When I read the proposal I had to think about the "ennnnnd" proposal. :)That one was linked in above:https://bugs.ruby-lang.org/issues/5054It's hard to say how serious people are, but I think...
View Article